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Preface

This isYour First Cup: An Introduction to Java Platform, Enterprise Edition, a short tutorial for
beginning Java EE programmers. This tutorial is designed to give you a hands-on lesson on
developing an enterprise application from initial coding to deployment.

WhoShouldUse This Book
This tutorial is for novice Java EE developers. You should be familiar with the Java programming
language, particularly the features introduced in Java Platform, Standard Edition 5.While familiarity
with enterprise development and Java EE technologies is helpful, this tutorial assumes you are new to
developing Java EE applications.

BeforeYouReadThis Book
Before you start this tutorial, you should:

� Be familiar with the Java programming language
� Be able to install software on your workmachine
� Have amodern web browser installed on your workmachine

RelatedBooks andProjects
The following books and projects may be helpful to you in understanding this tutorial:

� The Java EE 5 Tutorial
� The Sun Java System documentation

5



Related Third-PartyWebSite References
Third-party URLs are referenced in this document and provide additional, related information.

Note – Sun is not responsible for the availability of third-party web sitesmentioned in this document.
Sun does not endorse and is not responsible or liable for any content, advertising, products, or other
materials that are available on or through such sites or resources. Sun will not be responsible or liable
for any actual or alleged damage or loss caused or alleged to be caused by or in connection with use of
or reliance on any such content, goods, or services that are available on or through such sites or
resources.

Documentation, Support, andTraining
The Sunweb site provides information about the following additional resources:

� Documentation (http://www.sun.com/documentation/)
� Support (http://www.sun.com/support/)
� Training (http://www.sun.com/training/)

Typographic Conventions
The following table describes the typographic conventions that are used in this book.

TABLE P–1TypographicConventions

Typeface Meaning Example

AaBbCc123 The names of commands, files, and directories,
and onscreen computer output

Edit your .login file.

Use ls -a to list all files.

machine_name% you have mail.

AaBbCc123 What you type, contrasted with onscreen
computer output

machine_name% su

Password:

aabbcc123 Placeholder: replace with a real name or value The command to remove a file is rm
filename.

Preface
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TABLE P–1TypographicConventions (Continued)
Typeface Meaning Example

AaBbCc123 Book titles, new terms, and terms to be
emphasized

Read Chapter 6 in theUser’s Guide.

A cache is a copy that is stored
locally.

Do not save the file.

Note: Some emphasized items
appear bold online.

Shell Prompts in CommandExamples
The following table shows the default UNIX® system prompt and superuser prompt for the C shell,
Bourne shell, and Korn shell.

TABLE P–2Shell Prompts

Shell Prompt

C shell machine_name%

C shell for superuser machine_name#

Bourne shell and Korn shell $

Bourne shell and Korn shell for superuser #

Preface
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Introduction

An introduction to this tutorial. This chapter outlines the goals and the prerequisites for completing
this tutorial.

Goals of This Tutorial
At the completion of this tutorial, you will:

� Understand the basics of tiered applications
� Understand the basics of the Java EE platform
� Have created amulti-tiered Java EE application
� Have deployed and run your application on a Java EE server
� Knowwhere to go next formore information on the Java EE platform

Requirements for This Tutorial

AChecklist
To complete this tutorial, you need:

� The tutorial bundle
� The Java EE 5 Software Development Kit
� NetBeans 5.5 Beta (optional)

Getting the Tutorial Bundle
To get the tutorial bundle, go to the https://firstcup.dev.java.net/ site.

Getting the Java EE 5 SDK
To get the Java EE 5 SDK, go to http://java.sun.com/javaee/downloads/index.jsp.

1C H A P T E R 1
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GettingNetBeans 5.5Beta
To get NetBeans 5.5 Beta go to http://www.netbeans.info/downloads/download.php?type=5.5b.

Requirements for This Tutorial
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The Java Platform, Enterprise Edition

This chapter outlines the features of Java EE, how it differs from Java SE and JavaME, and the basic
concepts behind enterprise application development.

Differences between Java EE and Java SE
Java technology is both a programming language and a platform. The Java programming language is
a high-level object-oriented language that has a particular syntax and style.A Java platform is a
particular environment in which Java programming language applications run.

There are several Java platforms.Many developers, even long-time Java programming language
developers, do not understand how the different platforms relate to each other.

The JavaProgramming LanguagePlatforms
There are three platforms of the Java programming language:

� Java Platform, Standard Edition (Java SE)
� Java Platform, Enterprise Edition (Java EE)
� Java Platform,Micro Edition (JavaME)

All Java platforms consist of a Java VirtualMachine (VM) and an application programming interface
(API). The Java VirtualMachine is a program, for a particular hardware and software platform, that
runs Java applications.AnAPI is a collection of software components that you can use to create other
software components or applications. Each Java platform provides a virtual machine and anAPI, and
this allows applications written for that platform to run on any compatible systemwith all the
advantages of the Java programming language: platform-independence, power, stability,
ease-of-development, and security.

2C H A P T E R 2
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Java SE
Whenmost people think of the Java programming language, they think of the Java SEAPI. Java SE’s
API provides the core functionality of the Java programming language. It defines everything from
the basic types and objects of the Java programming language to high-level classes that are used for
networking, security, database access, graphical user interface (GUI) development, and XML
parsing.

In addition to the coreAPI, the Java SE platform consists of a virtual machine, development tools,
deployment technologies, and other class libraries and toolkits commonly used in Java applications.

Java EE
The Java EE platform is built on top of the Java SE platform. Java EE provides anAPI and runtime
environment for developing and running large-scale, multi-tiered, scalable, reliable, and secure
network applications.

JavaME
The JavaME platform provides anAPI and a small-footprint virtual machine for running Java
programming language applications on small devices, like cellular phones. TheAPI is a subset of the
Java SEAPI, along with special class libraries useful for small device application development. Java
ME applications are often clients of Java EE application services.

Overviewof EnterpriseApplications
This section describes enterprise applications and how they are designed and developed.

As stated above, the Java EE platform is designed to help developers create large-scale, multi-tiered,
scalable, reliable, and secure network applications.Ashorthand name for such applications is
“enterprise applications,” so called because these applications are designed to solve the problems
encountered by large enterprises. Enterprise applications are not only useful for large corporations,
agencies, and governments, however. The benefits of an enterprise application are helpful, even
essential, for individual developers and small organizations in an increasingly networked world.

The features that make enterprise applications powerful, like security and reliability, oftenmake
these applications complex. The Java EE platform is designed to reduce the complexity of enterprise
application development by providing a developmentmodel,API, and runtime environment that
allows developers to concentrate on functionality.

TieredApplications
In amulti-tiered application, the functionality of the application is separated into isolated functional
areas, called tiers. Typically, multi-tiered applications have a client tier, a middle tier, and a data tier
(often called the enterprise information systems tier). The client tier consists of a client program that
makes requests to themiddle tier. Themiddle tier’s business functions handle client requests and
process application data, storing it in a permanent datastore in the data tier.

Overview of EnterpriseApplications
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Java EE application development concentrates on themiddle tier tomake enterprise application
management easier, more robust, andmore secure.

TheClient Tier
The client tier consists of application clients that access a Java EE server and that are usually located
on a different machine from the server. The clients make requests to the server. The server processes
the requests and returns a response back to the client. Many different types of applications can be
Java EE clients, and they are not always, or even often Java applications. Clients can be a web browser,
a stand-alone application, or other servers, and they run on a different machine from the Java EE
server.

TheWebTier
The web tier consists of components that handle the interaction between clients and the business tier.
Its primary tasks are the following:

� Dynamically generate content in various formats for the client.
� Collect input from users of the client interface and return appropriate results from the

components in the business tier.
� Control the flow of screens or pages on the client.
� Maintain the state of data for a user’s session.
� Perform some basic logic and hold some data temporarily in JavaBeans components.

Java EE Technologies Used in theWebTier

The following Java EE technologies are used in the web tier in Java EE applications:

TABLE2–1

Technology Purpose

Servlets Java programming language classes that dynamically
process requests and construct responses, usually for
HTMLpages

JavaServer Pages (JSP) Text-based documents that are compiled into servlets
and define how dynamic content can be added to
static pages, such as HTMLpages.

JavaServer Faces technology Auser-interface component framework for web
applications that allows you to include UI
components (such as fields and buttons) on a page,
convert and validate UI component data, save UI
component data to server-side data stores, and
maintain component state.

Overview of EnterpriseApplications
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TABLE 2–1 (Continued)
Technology Purpose

JavaServer Pages Standard Tag Library Atag library that encapsulates core functionality
common to JSP pages

JavaBeans Components Objects that act as temporary data stores for the pages
of an application

TheBusiness Tier
The business tier consists of components that provide the business logic for an application. Business
logic is code that provides functionality to a particular business domain, like the financial industry, or
an e-commerce site. In a properly designed enterprise application, the core functionality exists in the
business tier components.

Java EE Technologies Used in the Business Tier

The following Java EE technologies are used in the business tier in Java EE applications:

� Enterprise JavaBeans (enterprise bean) components
� JAX-WSweb service endpoints
� Java PersistenceAPI entities

The Enterprise Information SystemsTier
The enterprise information systems (EIS) tier consists of database servers, enterprise resource
planning systems, and other legacy data sources, likemainframes. These resources typically are
located on a separatemachine than the Java EE server, and are accessed by components on the
business tier.

Java EE Technologies Used in the EIS Tier

The following Java EE technologies are used to access the EIS tier in Java EE applications:

� The Java Database ConnectivityAPI (JDBC)
� The Java PersistenceAPI
� The J2EE ConnectorArchitecture
� The Java TransactionAPI (JTA)

Overview of EnterpriseApplications
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Java EE Servers
AJava EE server is a server application that the implements the Java EE platformAPIs and provides
the standard Java EE services. Java EE servers are sometimes called application servers, because they
allow you to serve application data to clients, much as howweb servers serve web pages to web
browsers.

Java EE servers host several application component types that correspond to the tiers in a
multi-tiered application. The Java EE server provides services to these components in the form of a
container.

Java EEContainers
Java EE containers are the interface between the component and the lower-level functionality
provided by the Java EE platform to support that component. The functionality of the container is
defined by the Java EE platform, and is different for each component type. Nonetheless, the Java EE
server allows the different component types to work together to provide functionality in an
enterprise application.

TheWebContainer
The web container is the interface between web components and the web server.Aweb component
can be a servlet, a JSP page, or a JavaServer Faces page. The containermanages the component’s
lifecycle, dispatches requests to application components, and provides interfaces to context data,
such as information about the current request.

TheApplicationClient Container
The application client container is the interface between Java EE application clients, which are
special Java applications that use Java EE server components, and the Java EE server. The application
client container runs on the client machine, and is the gateway between the client application and the
Java EE server components that the client uses.

The EJBContainer
The EJB container is the interface between enterprise beans, which provide the business logic in a
Java EE application, and the Java EE server. The EJB container runs on the Java EE server and
manages the execution of an application’s enterprise beans.

Java EE Servers
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CreatingYour First Java EEApplication

This chapter gives an overview of the example application and step-by-step instructions on coding
the example application.

Architecture of the ExampleApplication
The example application consists of threemain components: DukesAgeService, a web service
endpoint; DukesBirthdayBean, an enterprise bean; and firstcup, a web application created with
JavaServer Faces technology.

DukesAgeService is a JAX-WS endpoint that calculates the age of Duke, the Javamascot. Duke was
born onMay 23, 1995, when the first demo of Java technology was publicly released.

DukesBirthdayBean is a stateless session bean that calculates the difference between the user’s age
andDuke’s age.

The firstcupweb application is a JavaServer Faces application that accesses DukesAgeService to
display Duke’s age, reads in a date provided by the user, accessesDukesBirthdayBean to calculate
who is older, and then displays the difference in years between the user andDuke.

The web application consists of the following:

� greeting.jsp: A JSP page with which a user can enter a date
� response.jsp: A JSP page that tells the user whether he or she is older or younger thanDuke,

based on the date the user entered in the greeting.jsp page
� DukesBDay.java: A JavaServer Facesmanaged bean that defines properties to hold the user’s

birth date, get Duke’s current age from the web service, and get the age difference between the
user andDuke from the enterprise bean.

� faces-config.xml: Afile used to configure resources for the JavaServer Faces application. In the
case of this application, the file configures a resource bundle containingmessages, themanaged
bean, DukesBDay, and the page navigation rules.

3C H A P T E R 3
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� web.xml: The web application’s deployment descriptor, which is used to configure certain aspects
of a web application when it is installed. In this case, it is used to provide amapping to the
application’s FacesServlet instance, which accepts incoming requests, passes them to the life
cycle for processing, and initializes resources.

Tiers in the ExampleApplication
The example application has one web tier component (the firstcupweb client) and two business tier
components (the DukesAgeServiceweb service and the DukesBirthdayBeanenterprise bean). The
user’s web browser is the client tier component, as it accesses the rest of the application through the
web tier. The example application does not access the EIS tier.

Java EE TechnologiesUsed in the ExampleApplication
The DukesAgeServiceweb service endpoint is a JAX-WS endpoint The DukesBirthdayBean
enterprise bean is a stateless session bean. The firstcupweb client is a JavaServer Faces application
that runs in the web container of the Java EE server.

Coding the ExampleApplication
This section describes how to code the example application.

Getting Started
Before you start coding the example, you need to perform some set-up tasks:

1. Register the server with your NetBeans IDE.
2. Create a directory for the example you will build.
3. Specify some settings.

� Register the ServerwithNetBeans

Launch theNetBeans IDE.

From themenu, select Tools→ServerManager.

Click Add Server.

In theAdd Server Instance dialog, select Sun Java SystemApplication Server from the Servermenu.

(Optional) Enter a name for the server in theNamefield.

1

2

3

4

5

Coding the ExampleApplication

Your First Cup:An Introduction to the Java EE Platform • June 6, 2006 (Beta)18



ClickNext.

Click Browse to find the location of theApplication Server installation.

ClickNext.

Enter the user name you chosewhen you installed theApplication Server in theAdminUsername
field.

Enter the password for this username in theAdmin Password field.

Click Finish.

Click Close.

� Create aDirectory for the Example

Create another directory at the same level as the exampledirectory and call it myexample. You’ll put
the First Cup application that youbuildwhile following this tutorial in this directory.

Copy the entire bp-project folder from the exampledirectory to the myexampledirectory.

� Specify SomeSettings

In the myexample/bp-project directory, copy the build.properties.sample file to
build.properties.

Open the build.properties file in a text editor.

Set the javaee.homeproperty to the path of your Application Server installation. Use forward
slashes in the path, even if you are on theWindowsplatform. For example, youwould enter
C:/myServer instead of C:\myServer.

Set the firstcup.tutorial.home property to the location of your firstcup tutorial installation,
such as C:/firstcup-1.0beta.

Change example to myexample in the path specifiedby the javaee.server.passwordfile property.

Open the admin-password.txt file from the myexample/bp-project directory in a text editor.

Set the AS_ADMIN_PASSWORD property to your Application Server password.

Save the build.properties and admin-password.txt files and close them.
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Creating theWebService Endpoint
The DukesAgeService endpoint is a simple web service.Web services are web-based applications
that use open, XML-based standards and transport protocols to exchange data with calling clients.
Both the requests and responses are sent as XMLdocuments, and are usually sent as HTTPpackets.
This makes interoperability between different systems and applications easy, as it is not necessary for
the client to know the underlying architecture of the server and vice-versa tomake a successful web
service call.

Web services are designed to be independent of the client. Typically web service endpoints are
publicly available to a wide variety of clients, and the clients are located throughout the internet. This
is called “loose coupling,” as the clients and servers are connected only by the standard XML-based
requests and responses. For this reason, DukesAgeServicewill be developed in its own application
module, and deployed separately from the DukesBirthdayBean enterprise bean and firstcupweb
client.

JAX-WSEndpoints
DukesAgeService is a JAX-WS endpoint implemented as a servlet. Servlets are web components that
run in the web container.

We’ll begin by creating a servlet class, then decorate the class with the @WebServiceannotation to
make the class a web service endpoint, and finally we will add the getDukesAgemethod to calculate
and returnDuke’s age.

Creating the Endpoint
In NetBeans or another editor, create a Java class source file called DukesAge.java in the
com.sun.firstcup.webservice package.

� Create theProject inNetBeans

Select File→NewProject.

SelectWeb in the Categories pane.

SelectWebApplication in the Projects pane.

ClickNext.

Set Project Name to firstcup-dukes-age.

Set the Project Location to <INSTALL>/myexample, inwhich INSTALL is the location of the firstcup
tutorial installation.

Select your Application Server from the Servermenu.

1

2

3

4

5

6

7

Coding the ExampleApplication

Your First Cup:An Introduction to the Java EE Platform • June 6, 2006 (Beta)20



Select Java EE 5 from the J2EEVersionmenu.

Set Context Path to /DukesAgeService

Click Finish.

You should now see themodule you created in the Projects pane.

From the Projects pane, right-click on the index.jspfile and select Delete. Click Yes in the dialog.

� Create the DukesAgeClass

Select File→NewFile.

Make sure firstcup-dukes-age is selected in the Projectmenu.

Select Java Classes in the Categories pane.

Select Java Class in the File Types pane.

ClickNext.

Set Class Name to DukesAge.

Set Package to com.sun.firstcup.webservice.

Click Finish.

You should now see the DukesAge.java file inside the com.sun.firstcup.webservice package in
the Projects pane. The DukesAge.java file should also be open in the editor pane.

� Annotate the DukesAgeClass as aWebService

Add a @WebService annotation to the class.
@WebService

public class DukesAge {

...

}

� Remove theDefault Constructor

Highlight the followingdefault constructor anddelete it, asweb service endpoints do not require a
default constructor.
public DukesAge() {

}
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� Add the getDukesAgeMethod

Create a public getDukesAgemethodwith a return type of int.

public int getDukesAge() {

}

Add a @WebMethod annotation to getDukesAge.

@WebMethod

public int getDukesAge() {

}

Add the following code to getDukesAge:

Calendar dukesBirthday = new GregorianCalendar(1995, Calendar.MAY, 23);

Calendar now = Calendar.getInstance();

int dukesAge = now.get(Calendar.YEAR) - dukesBirthday.get(Calendar.YEAR);

dukesBirthday.add(Calendar.YEAR, dukesAge);

if (now.before(dukesBirthday)) {

dukesAge--;

}

return dukesAge;

� Resolve the Import Statements

Right-click in the Editor.

Select Fix Imports.

In the Fix Imports dialog, choose the javax.jws.WebService package for the WebService class.

Select File→Save from themenu to save the file.

Building andDeploying theWebService

� Building DukesAgeService

Select firstcup-dukes-age in the Projects tab.

Right-click firstcup-dukes-age and select Build Project.
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� Deploying theWebService Endpoint
The DukesAgeService endpoint was packaged in aWAR file, firstcup-dukes-age.war. Now you’ll
deploy firstcup-dukes-age.war to theApplication Server. This task gives instructions on
deploying firstcup-dukes-age.war in NetBeans.

Select firstcup-dukes-age in the Projects tab.

Right-click firstcup-dukes-age and select Deploy Project.

Creating the Enterprise Bean
DukesBirthdayBean is a stateless session bean. Stateless session beans are beans that do notmaintain
a conversational state with a client.With stateless session beans the client makes isolated requests
that do not depend on any previous state or requests. If you require conversational state, you use
stateful session beans.

To create DukesBirthdayBean you need to create two Java source files: DukesBirthdayBean, the
enterprise bean class; and DukesBirthdayRemote, the enterprise bean business interface. The
enterprise bean class and the business interface are the only files you need to create an enterprise
bean.

Creating DukesBirthdayBean inNetBeans
This section has instructions for creating the enterprise application and DukesBirthdayBean
enterprise bean.

� Creating the EnterpriseApplication
In this task, you will create an enterprise application archive (EAR) that will contain the
DukesBirthdayBean enterprise bean and firstupweb client.

Select File→NewProject.

Select Enterprise in the Categories pane.

Select Enterprise Application in the Projects pane.

ClickNext.

Set Project Name to firstcup.

Set the Project Location to <INSTALL>/myexample.

By default thewizard creates an enterprise beanmodule firstcup-ejb and aweb application
module firstcup-war. Leave everything in the dialog as it is.
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Click Finish.

� Setting theContext Root
In this task, you will specify the context root to identify the web application in a J2EE server.

Expand the firstcupmodule in the Projects pane.

In the Configuration Files node, double-click the application.xml file.

In application.xml, locate the context-root element.

Change the context root from /firstcup-war to /firstcup.

Select File→ Save to save the file.

Right—click the firstcup-warmodule in the Projects pane.

Select Properties from thepopupmenu.

In the Categories tree, select Run.

Change the Context Path to /firstcup.

ClickOK.

� Creating the DukesBirthdayBeanEnterprise BeanClass
Now you’ll create the enterprise bean class and business interface source files in NetBeans. The
DukesBirthdayRemote business interface is a remote interface.

Select firstcup-ejbproject in the Projects tab.

Select File→NewFile.

Select Enterprise in the Categories pane.

Select Session Bean in the File Types pane.

ClickNext.

Set EJBName to DukesBirthdayBean.

Set the Package name to com.sun.firstcup.ejb.

Set the Session Type to Stateless.
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Uncheck Local and check Remote under Create Interface.

Click Finish.

� Modify DukesBirthdayBean.java
Now you’ll add the code that calculates the difference in age in years betweenDuke and the user.

In DukesBirthdayBean.java, delete the empty default constructor that NetBeans generated.

Directly after the class declaration, paste in the following code:
private static Logger logger =

Logger.getLogger("com.sun.firstcup.ejb.DukesBirthdayBean");

public int getAgeDifference(Date date) {

int ageDifference;

Calendar theirBirthday = new GregorianCalendar();

Calendar dukesBirthday = new GregorianCalendar(1995, Calendar.MAY, 23);

// Set the Calendar object to the passed in Date

theirBirthday.setTime(date);

// Subtract the user’s age from Duke’s age

ageDifference = dukesBirthday.get(Calendar.YEAR) -

theirBirthday.get(Calendar.YEAR);

logger.info("Raw ageDifference is: " + ageDifference);

// Check to see if Duke’s birthday occurs before the user’s. If so,

// subtract one from the age difference

if (dukesBirthday.before(theirBirthday) && (ageDifference > 0)) {

ageDifference--;

}

logger.info("Final ageDifference is: " + ageDifference);

return ageDifference;

}

Right-click in the editorwindowand select Fix Imports.

Choose the java.util.logging.Logger fully-qualifiedname for the Logger class.

Choose the java.util.Date fully-qualifiedname for the Date class.

ClickOK.

Right-clickwithin the new getAgeDifferencemethod and select EJBMethods→Add to Remote
Interface.
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Select File→Save.

� Modify DukesBirthdayRemote.java

Expand the firstcup-ejbmodule in the Projects pane.

Double-click DukesBirthdayRemote.java under Source Packages→com.sun.firstcup.ejb.

Right-click in the editorwindowand select Fix Imports.

Select java.util.Date as the fully-qualified class nameof the Date class and clickOK.

Remove the throws clause from themethoddefinition so that you are leftwith int
getAgeDifference(Date date);.

Select File→Save.

Creating theWebClient
To create the web client, you need to perform the following tasks:

� Set the firstcup-warmodule to support JavaServer Faces technology. This will create a web.xml
file that has amapping to FacesServlet.

� Create a web service client.
� Create a resource bundle to hold localizedmessages used by the JSP pages.
� Configure the resource bundle in the configuration file.
� Create the DukesBDaymanaged bean class.
� Configure DukesBDay in the configuration file.
� Create the greeting.jsp page.
� Configure the navigation rules in the configuration file.
� Create the response.jsp page.

Setting firstcup-war to support JavaServer Faces Technology
All JavaServer Faces applicationsmust include amapping to the FacesServlet instance in their
deployment descriptors. The FacesServlet instance accepts incoming requests, passes them to the
life cycle for processing, and initializes resources.

You create themapping to FacesServlet in the web application’s deployment descriptor. Rather
than adding themapping to the web.xml file directly, NetBeans will create the web.xml file and
perform themapping to FacesServlet for you when you specify that your web application supports
JavaServer Faces technology. To do this, perform the following task.
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� Setting firstcup-war to support JavaServer Faces technology

Right-click the firstcup-warmodule of the firstcup enterprise application in the Projects pane.

Select Properties from thepopupmenu.

Select Frameworks from the Categories tree.

Click Add.

Select JavaServer Faces from the list of choices in the dialog.

ClickOK.

Change the servlet URLmapping to /firstcupWeb/*.

This path will be the path to the FacesServlet instance.All requests must include this path in
between the application’s context path and the page in the URL. Users don’t have to include this path
in the URLbecause firstcup includes an index.jsp page that forwards users to the greeting.jsp
page when they enter the following URL:
http://localhost:8080/firstcup

De-select the Validate XMLcheckbox.

ClickOK.

The remaining steps tell you how to perform the forward to greeting.jsp from the index.jsp page.

Expand the firstcup-warmodule in the Projects pane anddouble-clickWebPages.

Right-click welcomeJSF.jsp, select Delete from thepopupmenu, and click Yes in the dialog.

Double-click index.jsp.

NetBeans generated this file when you created the firstcup project.

Delete everything on the page.

Enter the following in the index.jsppage:

<jsp:forward page="/firstcupWeb/greeting.jsp"/>

Save the file by selecting File→ Save from themenubar.
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Creating aWebService Client for the firstcup-warWebModule
The firstcup-warwebmodulemust consume the firstcup-dukes-ageweb service in order to get
Duke’s current age. For this to happen, you need to create a web service client for the firstcup-war
webmodule.

� Creating aWebService Client for thefirstcup-warWebModule

Select firstcup-war from the Project pane.

Select File→NewFile.

SelectWeb Services from the Categories pane.

SelectWeb Service client from the File Types pane.

ClickNext.

SelectWSDLURL.

Into theWSDLURLfield, enter the following location of theWSDLfile of theweb service that theweb
service clientwill consume.

http://localhost:8080/DukesAgeService/DukesAgeService?WSDL

Into the Package field, enter the followingpackagewhere the client fileswill be generated.

com.sun.firstcup.webservice

Click Finish.

Creating aResourceBundle
In this section, we’ll create the resource bundle that contains the static text and errormessages used
by the JSP pages. The firstcup client supports both English and Spanish locales. Therefore we need
to create two properties files, each of which will contain themessages for one of the locales.

� Creating aResourceBundle

Right-click firstcup-war in the Projects pane.

Select New→Properties File from thepopupmenu.

In theNewProperties File dialog, enter WebMessages in the File Namefield.

In the Folder field, enter src/java/com/sun/firstcup/web as the location of the file.
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Click Finish.

After NetBeans creates the properties file, enter the followingmessages or copy them fromhere to
the file:
Welcome=Hi. My name is Duke. Let us find out who is older -- You or me.

DukeIs=Duke is

YearsOldToday=years old today.

Instructions=Enter your birthday and click submit.

YourBD=Your birthday

Pattern=MM/dd/yyyy

DateError=Please enter the date in the form MM/dd/yyyy.

YouAre=You are

Year=year

Years=years

Older=older than Duke!

Younger=younger than Duke!

SameAge= the same age as Duke!

Submit=Submit

Back=Back

Thesemessages will be referenced from the JSP pages.

Save the file by selecting File→ Save from themenu.

To add the Spanish translations of themessages, copy the properties file
WebMessages_es.properties from
<INSTALL>/firstcup/example/firstcup/firstcup-war/src/java/com/sun/firstcup/webto
<INSTALL>/firstcup/myexample/firstcup/firstcup-war/src/java/com/sun/firstcup/web.
You can createmultiple properties files, each with a set of messages for a different locale. By storing
localized static text andmessages in resource bundles, you don’t need to create a separate set of JSP
pages for each locale.

Refresh the files in the application by selecting File→RefreshAll Files from themenubar.

Configuring theResourceBundle in theConfiguration File
Tomake the resource bundle available to the application, you need to configure it in the
configuration file, by performing the following task.

� Configuring theResourceBundle

Expand the firstcup-warmodule in the Projects pane.

Open the foldersWebPages→WEB-INF.

Double-click faces-config.xml.
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Before the end-tag of the faces-config element, add the following elements:

<application>

<resource-bundle>

<base-name>com.sun.firstcup.web.WebMessages</base-name>

<var>bundle</var>

</resource-bundle>

<locale-config>

<default-locale>en</default-locale>

<supported-locale>es</supported-locale>

</locale-config>

</application>

The base-name element of the resource-bundle element identifies the fully-qualified class name of
the resource bundle. The var element identifies the name by which the JSP pages will reference the
resource bundle. The locale-config element identifies the locales supported by the resource
bundle.

Save the file by selecting File→ Save from themenubar.

AddingaDependencyon the Enterprise BeanModule
The firstcup-warmodule depends on some classes in the firstcup-ejbmodule. You need to tell
NetBeans that this dependency exists by performing the following task.

� AddingaDependencyon the Enterprise BeanModule

Right-click the firstcup-warmodule in the Projects pane.

Select Properties.

Select Libraries from the Categories pane.

Select AddProject.

Navigate to <INSTALL>/myexample/firstcup.

Select the firstcup-ejbproject.

Click AddProject JAR Files.

Make sure Build Required Projects is selected.

ClickOK.
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Creating the DukesBDayManagedBeanClass
The DukesBDay JavaBeans component is a backing bean.Abacking bean is a JavaServer Faces
managed bean that acts as a temporary data storage for the values of the components included on a
particular JavaServer Faces page.Amanaged bean is a JavaBeans component that a JavaServer Faces
application instantiates and stores in scope. The section following this one describesmore about
managed beans and how to configure them.

This section describes how to create the DukesBDay class. To create the class you need to do the
following:

� Create an empty class.
� Decorate the bean with a web service reference and an enterprise bean reference.
� Add a property that accesses Duke’s current age from the web service.
� Add a property that accesses the user’s current birth date.
� Add a property that accesses the age difference from the DukesBirthdayBean enterprise bean.
� Add a property that acceses the absolute value of the age difference.

� Creating anempty class.

Right-click the firstcup-warmodule in the Projects pane.

Select New→ Java Class

Enter DukesBDay in the Class Namefield.

Enter com.sun.firstcup.web in the Package field.

Click Finish.

� AddinganEnterprise BeanReference

Directly after the class declaration, add aprivate variable to hold a reference to the enterprise bean
using the @EJB annotation:
@EJB

private DukesBirthdayRemote dukesBirthday;

� AddingProperties to theBean
During this task, you will add the following properties to the DukesBDay bean:

� age for getting Duke’s age from the web service.
� yourBD to hold the user’s birth date.
� ageDiff to get the age difference from the enterprise bean.
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� absAgeDiff to hold the absolute value of the age difference.

After the dukesBirthday variable declaration, add the following private variables:

private int age;

private Date yourBD;

private int ageDiff;

private int absAgeDiff;

Initialize the variables by adding the following inside the default constructor:

age = -1;

yourBD = null;

ageDiff = -1;

absAgeDiff = -1;

� Generating theAccessorMethods for theProperties

Right-click in the editorwindow.

Select Refactor→Encapsulate Fields from thepopupwindow.

In the Encapsulate Fields dialog, de-select the getDukesBirthday checkbox and the
setDukesBirthday checkbox.

ClickNext.

ClickDoRefactoring in the Refactoring pane at the bottomof the IDEwindow.

You should now see twomethods for each property, one to set the value and one to get the value of
the variable for that property.

� GettingDuke’s CurrentAge
While performing this task, you will add some code to the getAgemethod to access Duke’s current
age from the web service.

Expand the firstcup-warmodule.

Expand theWebService References node in the firstcup-warmodule.

Fromwithin theWebService References node, go to
DukesAgeService→DukesAgeService→DukesAgePort→getDukesAge.
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Drag the getDukesAge operation from inside the DukesAgePortnode to the getAgemethod in
DukesBDay.java in the editor, directly before the return age; statement so that your getAge
method looks like this:

public int getAge() {

try { // Call Web Service Operation

com.sun.firstcup.webservice.DukesAgeService service =

new com.sun.firstcup.webservice.DukesAgeService();

com.sun.firstcup.webservice.DukesAge port =

service.getDukesAgePort();

// TODO process result here

int result = port.getDukesAge();

System.out.println("Result = "+result);

} catch (Exception ex) {

// TODO handle custom exceptions here

}

return age;

}

In the getAgemethod of DukesBDay, change the line int result = port.getDukesAge(); so that
the age variable rather than the result variable is set to the result of the call to port.getDukesAge:

age = port.getDukesAge();

Remove the following line from the getAgemethod.

System.out.println(“Result = “+result);

� Getting theAgeDifference From the DukesBirthdayBean Enterprise
Bean
During this task, you will add code to the getAgeDiffmethod to get the difference in age between
the user’s age andDuke’s age from the EJB and to set the absAgeDiff variable to the absolute value of
the age difference.

Inside the getAgeDiffmethod, directly before the return statement, add the following code:

ageDiff = dukesBirthday.getAgeDifference(yourBD);

if(ageDiff < 0){

setAbsAgeDiff(Math.abs(ageDiff));

} else {

setAbsAgeDiff(ageDiff);

}
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� Adding Import Statements

Right-click in the editorwindow.

Select Fix Imports from thepopupmenu.

Select java.util.Date as the fully qualifiednameof the Date class.

ClickOK.

� Saving DukesBDay

Select File→ Save.

Configuring the DukesBDayBean in theConfiguration File
JavaServer Faces technology allows you to use the configuration file to initialize, configure, and store
managed beans in one of the following scopes:

� request, which begins when the user submits a page and ends when the response is rendered.
� session, which begins when a user first accesses a page and ends when the user’s session ends,

such as when the user’s session times out.
� application, which lasts until the server stops the application.

Once a bean is configured, a JavaServer Faces page can create and access the bean. In this section,
we’ll configure the DukesBDaymanaged bean.

� Configuring the DukesBDayManagedBean

Expand the firstcup-warmodule in the Projects pane.

Open the foldersWebPages→WEB-INF.

Double-click faces-config.xml.

Right-click in the editorwindowand select JavaServer Faces→AddManagedBean.

In theAddManagedBeandialog, enter dukesBDay in the BeanNamefield.

Enter com.sun.firstcup.web.DukesBDay in the BeanClass field.

Select session from the scopemenu.

Enter DukesBDay backing bean in the Bean Description field.
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Click Add.
You should now see the following in the faces-config.xml file:
<managed-bean>

<description>DukesBDay backing bean</description>

<managed-bean-name>dukesBDay</managed-bean-name>

<managed-bean-class>com.sun.firstcup.web.DukesBDay</managed-bean-class>

<managed-bean-scope>session</managed-bean-scope>

</managed-bean>

The managed-bean-name element is the name by which the JavaServer Faces pages will refer to the
bean. The managed-bean-class element is the fully-qualified class name of the bean. The
managed-bean-scope element is the scope in which the bean is saved.We specify session scope
because we need an instance of the bean to be available for the entire session so that all pages can
access the values held by the bean.

Select File→ Save to save the file.

Creating the greeting.jspPage
The greeting.jsp page includes the welcomemessage, displays Duke’s current age, and accepts the
user’s birth date. To create the page, you need to perform the following tasks:

� Create an empty JSP page.
� Declare the JavaServer Faces tag libraries.
� Add an f:view and an h:form tag.
� Add the output label components to display localizedmessages and text.
� Add an input component to accept the birth date.
� Register a converter on the input component to convert the date to the proper type.
� Add a custom errormessage to display if conversion fails.
� Add a button component so that the user can submit the page.

Creating an Empty JSPPage
To create an empty JSP page, do the following:

1. Right—click on the firstcup-warmodule in the Projects pane.
2. Select New→ JSP from the popupmenu.
3. Enter greeting in the JSP File Name field.
4. Click Finish.
5. In the greeting.jsp file, after the html tag, replace any head tag that is already in the page and

add the following one, which defines the content type:

<head>

<meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
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<title>Firstcup Greeting Page&lt;/title>

</head>

6. Remove the beginning and ending body tags.
7. Remove <h1>JSP Page</h1> from the file.
8. Select File→ Save to save the file.

Declaring the JavaServer Faces Tag Libraries

JavaServer Faces technology defines JSP custom tags for representing UI components, converters,
validators, and event listeners on a JSP page.Acustom tag provides a way to reference some Java logic
from a JSP page, thereby freeing page authors from including the logic in the page and allowing them
to reuse the logic by adding the same tag in any of their JSP pages. See the CustomTags chapter of the
Java EE tutorial (http://java.sun.com/javaee/5/docs/tutorial/doc) formore information.

Custom tags are defined in tag libraries. JavaServer Faces technology defines two tag libraries. The
HTMLRender Kit library defines all of the standardUI component tags. Each instance of a
component tag used on a page represents a corresponding stateful component object on the server.
The core tag library defines tags for representing type converters, data validators, event listeners, and
other objects and functions. Similarly to the component tags, each instance of a converter, validator
or listener tag represents an object on the server.

To use the tags in a page, you need to declare the tag libraries.

To declare the tag libraries, do the following:

1. After the ending head tag in greeting.jsp, add a taglib declaration for the HTMLrender kit
tag library:

<%@ taglib prefix="h" uri="http://java.sun.com/jsf/html" %>

When using a particular tag from this tag library, a page authormust use the prefix h: to specify
in which tag library the tag is defined. The uri resolves to the tag library definition.

2. After the taglib declaration from the previous step, add a taglib declaration for the core tag
library:

<%@ taglib prefix="f" uri="http://java.sun.com/jsf/core" %>

Again, when the page author uses a tag from this library, he or shemust use the f: prefix to
specify that the tag is defined in the core tag library.

Adding the f:view and f:form Tags

AJavaServer Faces page is represented by a tree of UI components.When a JavaServer Faces
implementation processes the page during the page’s life cycle, it will traverse the tree of components
and perform such tasks as converting the values of the components to the proper type, validate the
components’ values, and store the components’ values in backing beans.
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Every JSP page that uses JavaServer Faces technologymust include a view tag, which is defined in the
core tag library. The view tag represents the root of the component tree.All JavaServer Faces
component tagsmust be included inside the view tag.

A typical JavaServer Faces page also includes a form in which the user enters some data in input fields
and clicks a button to submit the form. If the page contains a form, it must also have a form tag.All
components that are part of the form submissionmust be inside the form tag.

To add the view and form tags to the page:

1. After the tag library declarations, add beginning and ending f:view tags:

<f:view>

</f:view>

2. In between the beginning and ending f:view tags, add beginning and ending h:form tags:

<f:view>

<h:form>

</h:form>

</f:view>

AddingOutput Labels toDisplay Read-only Content

One of themore commonly used component tags is the outputText tag, which represents a
read-only component that only displays content. The greeting.jsp page contains outputText tags
that display the welcomemessage, the instructions, the label for the input component, andDuke’s
current age.

The outputText tags that display the localizedmessages reference themessages from the resource
bundle that you configured previously. The outputText tag that displays Duke’s age references the
age from the age property of DukesBDay bean.

To reference values for display, the outputText tags use the expression language syntax defined by
the unified expression language. The expression language syntax allows you to use the . or []
notation to reference objects and their properties. The name by which an expression references an
object is defined in the configuration file. For example, an expressionmust refer to the WebMessages
resource bundle with the name bundle. Formore information on the expression language, see the
Expression Language section of the Introduction to JavaServer Pages chapter of the Java EE tutorial
(http://java.sun.com/javaee/5/docs/tutorial/doc).

While doing the following exercise, youmight want to refer to the WebMessages.properties file, the
DukesBDay bean, and the faces-config.xml file that you created earlier.

To reference the read-only values displayed on the greeting page using outputText tags and
expressions, add the following tags:

1. In between the beginning and ending h:form tags, add an outputText tag that displays “Hi. I’m
Duke. Let’s see who’s older - you orme.” and add some h2 tags around it.
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<h2><h:outputText value="#{bundle.Welcome}"/></h2>

The value attribute of the outputText tag specifies the text to display. In this case, the value
attribute uses an expression to reference themessage stored in the resource bundle, called
bundle, under the key, Welcome.

2. After the outputText tag you added in the previous step, add an outputText tag that displays
“Duke is”.Add an extra space between the closing curly brace and the double quote of the
expression so that there will be a space between “Duke Is” and the text following it on the page:

<h:outputText value="#{bundle.DukeIs} "/>

3. After the outputText tag you added in the previous step, add an outputText tag that displays
Duke’s age:

<h:outputText value="#{dukesBDay.age}"/>

The dukesBDay part of the expression refers to the DukesBDay bean. The age part of the
expression refers to the age property of DukesBDay bean.

4. After the outputText tag you added in the previous step, add a paragraph tag and another
outputText tag to display the instructions for filling out the form.

<p><h:outputText value="#{bundle.Instructions}"/>

5. After the outputText tag you added in the previous step, add another paragraph tag and an
outputText tag that displays the label for the input component.Add an extra space at the end of
this expression too:

<p><h:outputText value="#{bundle.YourBD} "/>

Add an Input Component toAccept theUser’s BirthDate
Another commonly used component tag is the inputText tag. This tag represents a text field, which
accepts input from the user. The inputText tag also uses expressions to reference values. However,
the inputText tag can use the expressions to set values as well as get them. The inputText tag on the
greeting.jsp page accepts the user’s birth date and sets this value into the yourBD property of the
DukesBDay bean.

To add the inputText tag, do the following:

1. Add a beginning and ending inputText tag, right after the previous outputText tag that you
added and give it an ID of userBirthday:

<h:inputText id="userBirthday">

</h:inputText>

Later, we’ll register a converter on this component.Any errormessages displayed as a result of
conversion failing will reference this id attribute.

2. Add to the inputText tag a value attribute that references the yourBD property of DukesBDay:
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<h:inputText id="userBirthday"

value="#{dukesBDay.yourBD}">

</h:inputText>

Registering a Converter on the Input Component
JavaServer Faces technology includes a set of standard converters and validators that you can register
on components in order to convert and validate their data. You register a converter or validator by
nesting the tag representing the converter or validator inside the input component’s tag.

To add a converter to the input component discussed in the previous section, do the following:

1. Add an f:convertDateTime tag inside the inputText tag and specify the acceptable format of
the input:

<h:inputText ...>

<f:convertDateTime pattern="MM/dd/yyyy" />

</h:inputText>

If the user does not enter something that can be converted to a Date type or the date the user
entered is not of the specified pattern then a conversion error occurs. The next section describes
how to create an errormessage and display it.

2. After the ending inputText tag, add an outputText tag that tells the user what the acceptable
pattern is.Add an extra space in between the double-quote and the pound sign of the expression
so that there will be space between the text field and the text displayed by this outputText tag:

<h:outputText value=" #{bundle.Pattern}"/>

Adding an ErrorMessage toDisplay if Conversion Fails
To specify an errormessage to be displayed if conversion fails, do the following:

1. Add a converterMessage attribute to the inputText tag and use it to specify the errormessage:

<h:inputText id="userBirthday"

value="#{dukesBDay.yourBD}"

converterMessage="#{bundle.DateError}">

</h:inputText>

If the conversion of the user’s input fails, the followingmessage, stored with the DateError key in
the resource bundle will display on the page:

Please enter the date in the format MM/dd/yyyy.

2. Add a paragraph tag followed by a message tag to indicate where the errormessagemust appear
on the page, right before the ending form tag:

<p><h:message for="userBirthday" style="color:red"/>

</h:form>

Coding the ExampleApplication

Chapter 3 • CreatingYour First Java EEApplication 39



The style attribute indicates the style of the errormessage. In this case, the errormessage text
will be red. The for attribute references the ID of the component that generated the error.

Add aButton for Submitting the Form

In order for the user to submit the formwith his or her birth date to the server, he or she needs to
click a button or a hyperlink, thereby causing a form submit.

To add a button to the page, do the following:

1. Right before themessage tag you added in the previous section, add the following paragraph tag
and commandButton tag:

<p><h:commandButton value="#{bundle.Submit}" action="success"/>

2. Save the file by selecting File→ Save from themenu.

The value attribute indicates the text that is displayed on the button.Again, you could use an
expression to refer to this value. The action attribute indicates a logical outcome, which tells the
page navigation systemwhich page to display next. The following section explains the navigation
system.

DefiningPageNavigation
JavaServer Faces technology supports a powerful rule-based system for defining the flow of pages in
an application. These rules are defined in the configuration file. To define the page navigation rules
for the firstcup application, do the following:

� DefiningPageNavigationRules

Expand the firstcup-warmodule in the Projects tree.

Open the foldersWebPages→WEB-INF.

Double-click faces-config.xml.

Right-click in the editorwindowand select JavaServer Faces→AddNavigation Rule.

In theAddNavigation Rule dialog, enter /greeting.jsp in the Rule fromViewfield.

Click Add.

Repeat steps 4 through 6 except enter /response.jsp in the Rule fromViewfield.

Right click in the editor again and select JavaServer Faces→AddNavigation Case.

Select /greeting.jsp from the FromViewmenu.
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Enter success in the FromOutcomefield.

Select /response.jsp from the ToViewmenu.

Click Add.

Repeat steps 8 through 12, except select /response.jsp from the FromViewmenu and select
/greeting.jsp from the ToViewmenu.
You should now see two navigation rules, one that defines how to navigate from greeting.jsp to
response.jsp, and another one that defines how to navigate from response.jsp to greeting.jsp.
The from-view-id tag indicates what the current page is. The to-view-id tag indicates what page to
go to next.

Recall from the section on adding a button that the commandButton tag has an action attribute that
indicates a logical outcome string.When the button is clicked, the navigation systemmatches the
current page ID and the logical outcome to a navigation rule.When it finds amatch, it will navigate
to the page that the rule specifies with its to-view-id tag.

Save the file by selecting File→ Save from themenubar.

Creating the response.jspPage
To create the response.jsp page, do the following:

1. Right—click the firstcup-warmodule.
2. Select New→ JSP from the popupmenu.
3. Enter response in the JSP File Name field.
4. Click Finish.
5. In the response.jsp file, after the html tag, replace any head tag in the file with the following

head tag, which defines the content type:

<head>

<meta http-equiv="Content-Type" content="text/html; charset=UTF-8">

<title>Response Page</title>

</head>

6. Remove the beginning and ending body tags.
7. Remove <h1>JSP Page</h2> from the file.
8. Add the following taglib declarations right after the ending head tag.

<%@ taglib uri="http://java.sun.com/jsf/html" prefix="h" %>

<%@ taglib uri="http://java.sun.com/jsf/core" prefix="f" %>

9. After the taglib declarations, add the beginning and ending f:view tags.
10. In between the beginning and ending f:view tags, add the beginning and ending h:form tags.
11. In between the beginning and ending h:form tags, add the following outputText tags:

10

11

12

13

14

Coding the ExampleApplication

Chapter 3 • CreatingYour First Java EEApplication 41



<h2><h:outputText value="#{bundle.YouAre} "/>

<h:outputText value="#{bundle.SameAge}" rendered="#{dukesBDay.ageDiff == 0}"/>

<h:outputText value="#{dukesBDay.absAgeDiff}" rendered="#{dukesBDay.ageDiff < 0}"/>

<h:outputText value=" #{bundle.Year} " rendered="#{dukesBDay.ageDiff == -1}"/>

<h:outputText value=" #{bundle.Years} " rendered="#{dukesBDay.ageDiff < -1}"/>

<h:outputText value="#{bundle.Younger}" rendered="#{dukesBDay.ageDiff < 0}"/>

<h:outputText value="#{dukesBDay.absAgeDiff}" rendered="#{dukesBDay.ageDiff > 0}"/>

<h:outputText value=" #{bundle.Year} " rendered="#{dukesBDay.ageDiff == 1}"/>

<h:outputText value=" #{bundle.Years} " rendered="#{dukesBDay.ageDiff > 1}"/>

<h:outputText value="#{bundle.Older}" rendered="#{dukesBDay.ageDiff > 0}"/>

The outputText tags on the response.jsp page use the rendered attribute to control which one
of the tags will actually have their content rendered. Let’s take a look at the set of outputText
tags:

The first tag will yield the text “You are”.

The rendered attribute of the second outputText tag references an expression that tests if the
ageDiff property of DukesBDay is equal to zero. If this expression returns true then themessage
referenced by the tag’s value attribute will be rendered. This message is “the same age as Duke”.

The value attribute of the third tag references the absAgeDiff property of DukesBDay. This
property holds the absolute value of the age difference. The expressions referenced by the
rendered attributes of the fourth and fifth tags test whether or not the age difference is equal t o
-1 or less than—1 to determine whether the age difference is only one year ormore than one year
so that “year” or “years” is rendered appropriately. The sixth tag tests if ageDiff is less than zero.
If this is true then the absolute value of the age difference is rendered along with themessage
”younger thanDuke!”. So an examplemessage that can be rendered by this group of tags is:

You are 10 years younger than Duke!

The last group of tags work similarly to the previous set of tags, except that their rendered
attributes test for age differences greater than zero, indicating that the user is older thanDuke.

12. Before the ending </h:form> tag, add the following paragraph tag and commandButton tag to
render a button used for returning to the greeting.jsp page.

<p><h:commandButton id="back" value="#{bundle.Back}" action="success"/>

13. Save the file by selecting File→ Save.

Building, Packaging,Deploying, andRunning the
firstcup EnterpriseApplication
In this section, you will build the DukesBirthdayBean and the firstcupweb client, package them
into an EAR file, deploy the EAR file to the server, and run the application.
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� Preparing theDeploymentDescriptor
In this task, you will remove some extra parameters from the deployment descriptor of the
firstcup-warmodule. NetBeans generates these parameters, but we don’t need them in our
example.

Expand the firstcup-warmodule in the Projects pane.

Expand the Configuration Files directory.

Double-click web.xml.

Click General at the top of the editorwindow.

Select the plus sign next to Context Parameters.

From the table of context parameters, select the first context parameter in the table and click
Remove.

Repeat step 6 until all context parameters are removed.

Click XMLat the top of the editorwindow.

Remove the entire welcome-file-list element and all its contents.

Save the file by selecting File→Save from themenubar.

� Building andPackaging the firstcup EnterpriseApplication
While performing this task, you’ll build and package the DukesBirthdayBean enterprise bean and
the firstcupweb client into an EAR file, firstcup.ear, in the dist directory.

Select firstcup in the Projects tab.

Right-click firstcup and select Build Project.

� Deploying the firstcup EnterpriseApplication
While performing the previous task, you packaged the DukesBirthdayBean enterprise bean and
firstcupweb client into the firstcup.ear file. Now you’ll deploy them to theApplication Server.

Select firstcup in the Projects tab.

Right-click firstcup and select Deploy Project.
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� Running the firstcupApplication
This section describes how to run the firstcup application.

Launch an internet browser.

Enter the followingURL in the address field of the browser:
http://localhost:8080/firstcup

Enter your birth date in the Your birthday text field.Make sure youuse the date pattern specified on
the page:MM/dd/yyyy.

Click Submit.

After the response.jsppage is launched, click Back to return to the greeting.jsppage.

1

2

3

4

5

Coding the ExampleApplication

Your First Cup:An Introduction to the Java EE Platform • June 6, 2006 (Beta)44



Building, Packaging, andDeploying and
Running the ExampleApplication

This chapter details how to build, deploy, and run the pre-coded example application included in the
firstcup download bundle using theAnt build tool. If you want to build, deploy, and run the
example that you built in the previous chapter, please use NetBeans rather than theAnt build tool by
following the instructions in the previous chapter.

Building andPackaging the ExampleApplication
This section describes how to build the example application.

Building andPackaging the ExampleApplication
using ant

� Building andPackaging firstcup-dukes-ageusing ant
After you complete this task will build firstcup-dukes-age and create aWAR file,
firstcup-dukes-age.war in the dist directory.

Verify that youhave added theAnt build tool that comeswith theApplication Server to your path.
The location is the lib/ant/bindirectory of your Application Server installation.

In a terminal, go to <INSTALL>/firstcup/example/firstcup-dukes-age.

If you are building the version of the example you created in the previous chapter rather than the
pre-bundled example code, copy the

Enter the following command:
ant

You should see Build Successful when the command finishes.
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� Deploying firstcup-dukes-age.warusing ant
This task gives instructions on deploying firstcup-dukes-age.war using ant.

Start theApplication Server if you haven’t already. Refer to your Application Server documentation if
you are not sure how to start the server.

In a terminal go to <INSTALL>/firstcup/example/firstcup-dukes-age.

Enter the following command:
ant deploy

You should see Build Successful when the command finishes.

� Building andPackaging DukesBirthdayBean and firstcupusing ant

In a terminal, go to <INSTALL>/firstcup/example/firstcup.

Enter the following command:
ant

You should see Build Successful when the command finishes.

Deploying the ExampleApplication
This section describes how to deploy the example application.

Deploying the Enterprise BeanandWebClient
The DukesBirthdayBean enterprise bean and firstcupweb client were packaged in firstcup.ear.
Now you’ll deploy them to theApplication Server.

� Deploying firstcup.earusing ant
This task gives instructions on deploying firstcup.ear using ant.

In a terminal go to <INSTALL>/firstcup/example/firstcup.

Enter the following command:
ant deploy

You should see Build Successful when the command finishes.
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Running theWebClient
This section describes how to run the firstcup application.

To run the application, do the following.

� Running the firstcupApplication
Launch an internet browser.

Enter the followingURL in the address field of the browser:
http://localhost:8080/firstcup

Enter your birth date in the Your birthday text field.Make sure youuse the date pattern specified on
the page:MM/dd/yyyy.

Click Submit.

After the response.jsppage is launched, click Back to return to the greeting.jsppage.

Undeploying theApplication

� UndeployingwithAnt
Go to the <INSTALL>/firstcup/example/firstcup directory.

Run ant undeploy.

Go to the <INSTALL>/firstcup/example/firstcup-dukes-age directory.

Run ant undeploy.

� UndeployingwithAsadmin
Run asadmin undeploy firstcup-dukes-age.

Run asadmin undeploy firstcup.
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Next Steps

This chapter points the user at additional resources for learningmore about enterprise application
architecture, the Java EE platform, and theApplication Server.

The Java EE Tutorial
The http://java.sun.com/javaee/5/docs/tutorial/doc documents the technologies that make
up the Java EE platform. The Java EE Tutorial describes each piece of the platform in detail, and
includes code examples that demonstrate how to use each piece of the platform.

More Informationon the Java EEPlatform
Formore information on the Java EE platform, see these resources:

� http://java.sun.com/javaee

� https://glassfish.dev.java.net

� http://blogs.sun.com/roller/page/theaquarium

Java EE Servers
Java EE servers are application servers that implement the Java EE platform technologies.

The Sun Java SystemApplication Server
The Sun Java SystemApplication Server is the reference implementation of the Java EE platform
APIs.
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Glassfish
The https://glassfish.dev.java.net project is the open-source basis for the Sun Java System
Application Server.

Other Java EE Servers
There are several other popular Java EE servers used by developers and enterprises.

Java EE Servers
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